Samstag, 20. Juli 2013

Tag 2: Oh je, hätte ich mal in der Berufsschule besser aufgepasst!

Am Mittwoch den 10. Juli sollte dann auch endlich meine Festplatte und die Speicherkarte geliefert werden. Nachdem ich den Tag vorher doch noch alles relativ gut hinbekommen habe, trotz meines Ausflugs zu Saturn war ich an diesem Tag sehr guter Dinge, schließlich musste ich eigentlich nur noch die Festplatte kriegen und alles drauf kopieren und dann ans Pi hängen.

Soweit zur Theorie!

Also hab ich wieder brav meine Festplatte verfolgt wo sie grade steckt und gehofft das sie rechtzeitig ankommt, hatte auch von Amazon die Info bekommen das sie voraussichtlich am 10. geliefert werden soll.

Normalerweise erhalte ich meist gegen Mittag schon die Nachricht das ich was in meiner Packstation abholen kann, an diesem Tag nicht! Der Status der Paketverfolgung machte mir auch sorgen, der hatte sich seit dem Tag zuvor nicht mehr geändert und stand weiterhin auf "Sendung ist beim Verteilzentrum eingegangen." Oh je das Teil kommt doch nie rechtzeitig an.


Als ich dann Nachmittag Feierabend gemacht habe kam es wie es kommen musste die Festplatte war noch nicht da. Also hab ich mich kurzerhand entschlossen mir die Platte bei Saturn zu kaufen, da ich dachte dort hat sie dasselbe gekostet. Also dort fix geparkt und noch überlegt dass ich jetzt eigentlich kein Parkticket brauche, will ja nur fix die Platte holen. Wie ich diesen Gedanken aber grad zu Ende gedacht hab kommt ein netter Ordnungshüter vorbei und kontrolliert die Autos, also stell ich mich vorbildlich an den Automaten um ein Ticket zu lösen. Hab dann aber feststellen müssen dass mein Kleingeld nicht für die Mindestgebühr reicht und so hab ich den Vorgang wieder storniert und der Mann vom Ordnungsamt war auch an mir vorbei.
Ein Schelm wer Böses dabei denkt!
Da ich aber vorbildlich bin und außerdem sehe dass der Mann die Strecke wieder zurückgehen will, frage ich höflich nach wie das denn jetzt ist mit meinem wenigen Kleingeld.
Der nette Mann erklärt mir dass ich eine viertel Stunde Zeit habe.
Das reicht mir locker und ich renne fast zu Saturn.
Bei Saturn merke ich das die Platte die ich in Erinnerung hatte nur eine 0,5TB Platte ist  und ich finde die 1TB Platte nicht. Nach einer Weile finde ich dann die letzten Beiden 1TB Platten, nur stand da kein Preis dran. Also noch fix nen Mitarbeiter suchen. Zufälliger Weise hab ich dann auch relativ schnell einen gefunden, das lag wahrscheinlich dran das ich immer noch in Eile war und er nicht so schnell flüchten konnte. Gut die Platte kostet 69,99€ also das gleiche wie bei Amazon das passt ja. (Mittlerweile weiß ich dass ich damit falsch lag, die bei Amazon hat nur 62,99 gekostet)
Also fix zurück zum Auto und ich hab noch alles in der Zeit geschafft, ich bin stolz auf meine sportliche Leistung.

Zu Hause wird dann gleich die Platte an den PC gehangen und
NIX PASSIERT!
Das Problem hatte ich am Wochenende schon mit einer anderen Festplatte, nachdem ich die dann an USB2.0 gehangen hab ging da wieder alles. Ok also auch meine Platte an den normalen USB Port gehangen und angefangen die ersten Daten zu kopieren.
Restdauer circa 4 Stunden!? Die wollen mich doch verarschen!
Naja nutze ich die Zeit um mein USB3.0 Problem zu lösen, dann kann ich den Rest wenigstens schneller kopieren.
Nur hab ich keine Ahnung was das Problem sein kann, ich hab bisher noch keine Erfahrungen mit USB3.0 gemacht. Google konnte mir da auch auf Anhieb nicht weiterhelfen, also mal bei Facebook angefragt. Da hab ich dann recht schnell nen hilfreichen Link bekommen, aber auch da stand nix drin was mein Problem lösen konnte. Also hab ich erst mal nen bissl aufgeräumt und bin duschen gegangen. Da ist mir dann eingefallen das es ja vielleicht im BIOS ne Einstellung geben könnte. Soweit so gut. Mittlerweile war die Restdauer beim Kopieren runter auf eine Stunde gegangen. Na gut das geht ja noch.

Den Abend vorher ist mir noch aufgefallen das bei der Wiedergabe im Vollbild eine Navigation mit der Fernbedienung ins Hauptmenü nicht möglich ist. Das ist natürlich doof, aber hier hab ich schnell eine Lösung online gefunden. 
Jetzt musste ich nur noch rausfinden wie ich in diese config Datei komme.
Die Lösung hieß PUTTY!
Oh Gott, warum nur. Plötzlich wurden Erinnerungen an die Berufsschule wach. Oh je! Oh je!
Aber da muss ich jetzt durch, also PUTTY auf den PC geladen und gestartet, der Zugriff auf das Pi war denn recht schnell erfolgt, jetzt musste ich nur noch die richtigen Befehle kennen. Nur doof das ich mich an nicht viel mehr als cd erinnern konnte. Aber auch hier ist Google natürlich dein Freund und so hatte ich dann die nötige Datei gefunden, kopiert und auch editiert.
Editieren der Fernbedienungs config in Nano





























Siehe da, wie von Zauberhand konnte ich jetzt auch mit der Fernbedienung bei Vollbild ins Menü gehen.
Näheres dazu schreibe ich mal in einem späteren Beitrag, wenn ich mit der Hauptstory durch bin. 
Nachdem die Platte dann endlich fertig war gings gleich ins BIOS, aber auch da konnte ich nix finden. Nach weiterem googlen habe ich dann erfahren dass man den Treiber häufig selbst installieren muss. Also nach nem passenden Treiber gesucht, doch da wollten die plötzlich was von irgendwelchen Chipsätzen wissen. Da stand ich also wieder aufm Schlauch. Dann kam mir ein Gedanke der mir hätte viel eher kommen müssen.
Guck doch einfach mal bei den Treibern die zum Mainboard dazu waren!
Aber auch das wäre zu einfach gewesen, nach weiterem googlen erfahre ich dass dieser Treiber bei meinem Mainboard (LINK) nicht dabei ist. Zum Glück gibt’s da dann aber gleich noch nen Link für den Download und siehe da alles funktioniert wunderbar.
Die restlichen Daten waren dann schnell kopiert und ich konnte die Platte endlich ans Pi hängen.
Ich hab die Platte dann an das laufende Pi gehängt und plötzlich wird das Bild schwarz und das Pi startet neu!
Merkwürdig, aber vielleicht soll man die Platte nicht im laufenden Betrieb anhängen.
Nachdem das Pi dann wieder gestartet war bin ich auf die Suche nach der Platte gegangen, konnte sie aber nirgends im Raspbmc finden.

Also wieder zurück zu Google!

Da gibt es plötzlich noch mehr bei denen die Platte nicht erkannt wird und ich erfahre dass man die Platten eventuell erst mounten muss und die in irgendwelche Tabellen eingetragen werden müssen.
Hier bin ich dann auch auf ein paar nützliche Forenbeiträge gestoßen, wie zum Beispiel das hier
Nur leider ist dabei bei mir ein weiterer Fehler aufgetreten und ich hatte langsam das Gefühl immer weiter in einem Sumpf zu versinken. Dabei bin ich dann auf diesen Beitrag gestoßen
aber auch das ging alles andere als problemlos. Nichts desto trotz hab ich es weiter versucht und bin immer tiefer in irgendwelchen Dateien versunken in denen ich was löschen sollte oder deinstallieren und reinstallieren sollte.





























Wenn das mein Lehrer in der Berufsschule gesehen hätte, der hätte mir im Nachhinein noch eine bessere Note gegeben.

Aber trotzdem blieb alles ohne Erfolg!

Dann in einem ruhigen Moment höre ich plötzlich ein Klicken am Raspberry, bei genauerem Hinhören kam das Klicken von der Festplatte.
Ach du Scheiße, ist die Platte kaputt?!
Fix die Platte an den PC  gehangen und da ging Sie zum Glück, aber jetzt hab ich schon mal nen neuen Punkt zum Ansetzen bei der Fehlersuche. Ich hab das Pi dann mal an das Ladegerät vom iPhone gehängt damit es mehr Strom bekommt, vielleicht liegt es ja die ganze Zeit daran. Das würde auch erklären warum es neustartet wenn ich die Platte anhänge. Das Klicken war immer noch da, es klang aber jetzt anders. Es klang jetzt viel mehr danach das die Platte versucht zu starten, aber dann abbricht.
OK, ich glaube ich bin auf der richtigen Spur!
Ich hab dann mal meine alte externe Platte angehängt, die hat 2 USB Stecker damit sie mehr Strom bekommt, den 2. Stecker hab ich aber nicht ans Pi gehangen, sondern dann an das Netzteil vom iPhone und plötzlich ging alles wunderbar und die Platte wurde sofort erkannt.
Ich hab auch keine Ahnung ob meine ganzen Voreinstellungen irgendwas dazu beigetragen haben und ich einfach Probleme schon damit gelöst hatte bevor sie auftraten, aber ich rede es mir mal ein.

Fazit nach dem zweiten Tag mit meinem Pi:

Ich habe verdammt viel über die Arbeit im Terminal gelernt und wenn man da nen Sinn drin sieht macht das auch ein wenig Spaß und bei den nächsten Änderungen freue ich mich sogar ein bisschen drauf. Es ist halt wirklich toll dass man alles ändern kann, bei einem anderen Gerät hätte ich wohl kaum einfach die config Datei der Fernbedienung ändern können wie ich will.
Und ganz wichtig, morgen geht es mal wieder zu Saturn. Ich brauche ja jetzt einen Powered USB Hub.